
 

Westminster College 1 Base Windows XP Image Build Document 

05-06 Base Windows XP Image Build Document 
Document last modified: 4/25/2006 F:\usr\it\computer images 

Computer make/model/image name: _____________________________________ 

IT staff member building image: _________________________________________ 

1. Install Windows XP w/ Service Pack 2 
Boot from CD.  Delete any existing partitions.  Format for NTFS file system. 

 REMOVE: File and Print Sharing 

 REMOVE: QoS Packet Scheduler 

 CONFIGURE: Internet Protocol (TCP/IP): 

� DISABLE: Advanced > DNS > Register this Connection’s addresses in DNS 

� DISABLE: Advanced > WINS > Enable LMHOSTS lookup 

 Name: Anyone 

 Organization: Westminster 

 Computer Name: MakeModelIMB (e.g. Micron650Img) 

 Connect through LAN 

 Do not set administrator password 

 Do not register 

 Create “IT” account 

 Create “Temp” account 

 Log in to both accounts 

 Reboot 

2. Update Hardware Drivers 
 Compaq D51c (I:\WINxp\DRIVERS\HP-Compaq\README-d51c.txt) 

 HP D530c (I:\WINxp\DRIVERS\HP-Compaq\README-d530c.txt) 

 Epower-04 (I:\WINxp\DRIVERS\Epower-04\README-Epower04.txt) 

 Epower-05 (Still testing) 

 Micron, Dell 4500, Dell GX150, Dell GX100, IBM 1.6 use Windows Update drivers 

3. Update Windows XP 
Go to www.microsoft.com and select Microsoft Update. 

 INSTALL: latest version of Microsoft Update 
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 INSTALL: all critical updates 

 INSTALL: Media Player 10 

 INSTALL: Hi-MAT CD burning support (KB831240) 

 CONFIGURE: Control Panel > Security Center > Virus Protection > 
Recommendations 

� SET: Check “I’ll Monitor AntiVirus Myself” 

4. Remove Windows Components 
Control Panel > Add or Remove Programs > Add/Remove Windows Components 

 REMOVE: Messenger Service 
To display, edit c:\windows\inf\sysoc.inf.  Remove word “hide” but not commas. 
msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7 

 REMOVE: Messenger Program 

 REMOVE: Network Services > Internet Gateway Device Discovery and Control 
Client 

 REMOVE: MSN Explorer 

 REMOVE: Outlook Express 

5. Configure System Properties 
Control Panel > System 

 DISABLE: System Restore 

 DISABLE: Remote Assistance 

 SET: Automatic Updates: Download and install 4:00PM every day 

 SET: Computer Name > Change > More: Primary DNS Suffix to 
westminstercollege.edu 

 Advanced > Performance > Visual Effects > Settings 

� ENABLE: “Adjust for best Performance” 

� ENABLE: “Smooth edges of screen fonts” 

 Advanced > Startup and Recovery > Settings 

� DISABLE: Send Administrative Alert 

� SET: Write Debugging Information to “none” 

 Advanced > Error Reporting  

� DISABLE: Error Reporting 

6. Configure Users 
Control Panel > Users 

 Disable Welcome Screen 
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 Disable Fast User Switching 

7. Configure Desktop 
 Control Panel > Taskbar and Start Menu > Properties 

� DISABLE: Group similar taskbar buttons 

� DISABLE: Hide inactive  

� ENABLE: Show Quick Launch 

� SET: Start Menu to Classic Start Menu 

 DISABLE: Use Personalized Menus 

 ENABLE: Display Log Off 

 ENABLE: Display Favorites 

 ENABLE: Show Small Icons in Start Menu 

 Control Panel > Display Properties 

� SET: Themes to Windows Classic 

� Desktop > Customize Desktop 

 DISABLE: “Run Desktop Cleanup Wizard Every 60 days” 

 CONFIGURE Screen Saver: 

○ SET: to 3D Text “Westminster College” 

○ SET: Wait to 15 minutes 

○ SET: Power – set to presentation 

 DISABLE: Power: Hibernation 

� Appearance > Effects 

 DISABLE: “Use the following transition effect for menus and tooltips:” 

 SET: method to smooth edges of screen fonts to “Cleartype” 

 SET: My Documents to “h:\data\myfiles” and rename to My Files 

8. Configure Folder Options 
Browse files with Windows Explorer. 

 SET: View to “Details” 

 ENABLE: Status Bar 

 CONFIGURE: Tools > Folder Options: 

� ENABLE: Display the full path in the title bar 

� ENABLE: Launch folder windows in a separate process 

� DISABLE: Automatically search for network folders and printers 

� DISABLE: Hide extensions for known file types 

� DISABLE: Enable Offline Files 
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� Apply to all Folders 

 SET: View for Control panel to Icons 

9. Configure Search 
 Turn off animated assistant 

10. Configure Internet Explorer 
Internet Explorer > Tools > Internet Options 

 General 

� SET: home page to Westminster home page 

� CONFIGURE: Temporary Internet Files > Settings 

 SET: Check newer versions of stored pages to “Every Visit to the Page” 

 SET: Amount of disk space to use to 1MB 

 SET: History to 1 day 

 Security > Custom Level… 

� ENABLE: Downloads > Automatic Prompting for File Downloads 

 Privacy > Pop-Up Blocker > Settings 

� SET: add *.westminstercollege.edu to list of exceptions 

 Content > Auto Complete 

� DISABLE: All 

� ENABLE: Web Addresses 

� Clear Forms 

� Clear Passwords 

 Advanced 

� Browsing 

 DISABLE: Reuse windows for launching shortcuts 

� Multimedia 

 DISABLE: Enable Automatic Image Resizing 

 DISABLE: Enable Image Toolbar 

� Security 

 DISABLE: Enable Profile Assistant 

 DISABLE: Warn if changing between secure and not secure mode 

 ENABLE: Empty temporary internet files when browser is closed 

 ENABLE: Do not save encrypted pages to disk 

 Right click on Toolbar > Customize 

� SET: icons as small and remove edit icon 
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 Move Links toolbar below standard toolbar 

 Lock the toolbars 

11. Install MS Office Professional 2003 
 Custom Install 

 Deselect Microsoft Outlook 

 Select “Choose detailed installation options for each application 

� Microsoft Access: All except Database Replication 

� Excel: All 

� InfoPath: All 

� PowerPoint: All 

� Publisher: All 

� Word: All 

� Office Shared 

 Clip Organizers: All 

 Converters and Filters: All 

 International Support: All 

 Office Assistant: All 

 Proofing Tools: All 

 Themes: All 

 Visual Basic for Applications: All 

� Office Tools: All 

12. Install MS Visio Professional 2003 
 Custom Install 

 Microsoft Visio for Windows: All 

 Office Shared 

� International Support: All 

� Proofing Tools: All 

� Visual Basic for Applications: All 

 Office Tools: All 

13. Install MS Project Standard 2003 
 Custom Install 

 Microsoft Project for Windows: All 

 Office Shared: 
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� Converters and Filters: All 

� International Support: All 

� Office Assistant: All 

� Proofing Tools: All 

� Visual Basic for Applications: All 

 Office Tools: All 

14. Run Office Update  
 www.microsoft.com and select Office Update 

15. Install and Configure Novell Client 
 Download from: W:\Tools\w2k-XP\Current Client 

� Get folders: 1 - Client and 2 - Patch 

 Run clnt491e.exe from 1 - Client.  Use the custom install option 

� ENABLE: IP only 

� SET: Remove IPX if present 

� ENABLE: NMAS 

� DISABLE: Net Identity Agent 

� ENABLE: NDS 

 Reboot 

 CONFIGURE: Novell Client (right click on N and select Properties) 

� DHCP Settings Tab > check Use Server, Binary Data, and Use Tree 

� Advanced Menu Settings Tab:  “Enable Purge Dialog” to off 

� Advanced Menu Settings Tab:  “Enable Send Messages” to off 

� Advanced Settings Tab: “SLP Active Discovery” to off 

� Enable LDAP contextless login 

 Set "Enable LDAP context login" 

 Tree = wcslc_ut 

 Servers (any order) 146.86.1.3, 146.86.1.14, 146.86.1.6 

 Settings >  User Search Failure = continue 

 Reboot 

 From the command line, run patch.bat from 2 - Patch. 

 Reboot 

16. Install Miscellaneous Software 
Restart the computer after each individual installation. 
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 Adobe Acrobat Reader 7.0  
I:\area51\Image Stuff\Acrobat Reader\AdbeRdr70_enu_full.exe 

 Flash player (www.macromedia.com). Do not install Yahoo Toolbar. 

 Shockwave player (http:///www.macromedia.com).  Do not install Yahoo Toolbar. 

 SPSS client  
I:\cfgapps\SPSS13\SPSS 13.0 for Windows.msi 
License server is shishi.westminstercollege.edu.  Delete Start menu shortcuts. 

 Quark Xpress 6 
Install from disk. 
Serial:  QC8QM-JVSPD7HXEN4HXV9MZE82U2Q6KE5XBAPDFMVJ73SHTC 
Version 5 serial: WX43964656605 

 QuickTime 6.5 
I:\area51\image stuff\quicktime\QuickTimeFullInstaller.exe 
Install and tell it not to change associations and not to prompt again.  After 
installation, run QuickTime update. 

 SecureFTP 
I:\area51\licensed software\VanDyke\sfx30.exe 
Common profile, no shortcuts. 

 JVM 
I:\area51\java\jdk-1_5_0_04-windows-i586-p.exe 
 ***note: you must change the registry in the Textpad program to reflect the 
new install path* 

 Library eReader 
site.ebrary.com/lib/wminslc 
Install Active X control, return to page, install plug-in. 

 Refworks Plug-in 
I:\area51\Image Stuff\Refworks\wncinstall.exe 

 VirusScan Agent 
 people.westminstercollege.edu/tools/w2k-XP/epolicy/FramePkg.exe 
Save to desktop, run from command prompt “framepkg /install=agent” 

 Chime 
I:\area51\Image Stuff\MDL\Chime\MDLChime26SP6.exe 

 ISIS/Draw 
I:\area51\Image Stuff\MDL\draw\draw25.exe 

 Crystal Ball 
I:\area51\Image Stuff\Crystal Ball\cb550.exe)  
License server: cb.westminstercollege.edu 

 Crystal Ball Tutorials 
I:\area51\Image Stuff\Crystal Ball\cbtutorial_100.exe 

 Real Player 
I:\area51\Image Stuff\RealPlayer\ rp10-bbc-en-setup.exe 

� Username: rlewis@westminstercollege.edu Password: westminster 

� UNCHECK: everything under Desktop Settings 

� UNCHECK: everything under Customize Media Types 
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 iPrint Client 
Install from iprint1.wcslc.edu:631/ipp 

� W:\Tools\Patches\iprint-hotfix\WindowsXP-KB893225-v2-x86-ENU.exe 

 Install McAfee Virus Scan 
Install from W:\Tools\nai\VSE80iLEN\Setup.exe 

� SET: choose perpetual agreement 

� SET: custom install 

� DISABLE: scan email 

� DISABLE: “Scan floppy on shutdown”  

� SET: Password: hateclowns 

� Reboot, then run Patch10 (W:\tools\nai\HOTFIX\8.0PATCH10-
VSE80P10\setup.exe) 

� Reboot, then run Hotfix HF212581 
(W:\tools\nai\HOTFIX\VSE80HF212581\VSE80HF212581.Exe) 

17. Install GroupWise Client 6.5 
Install from G:\Software\client\win32\setup.exe 

 Install Windows Messaging 

 Standard Install 

 DISABLE: GroupWise tip of the day 

 DISABLE: GroupWise application integration 

 ENABLE: email browser integration 

 SET: Address book arranged: Last, First, Full, UserID, Email, Office Phone 

 Tools > Options > Environment 

� SET: Default Actions: Sent Items = Open Item 

� SET: Default Actions: Web browser = Open in a new window 

� SET: Default Actions: Attachments = Open attachment 

� SET: Views: Default Compose View = Plain Text 

� SET: Views: Default Read View = HTML 

18. Configure Office 2003 
 Access 

� ENABLE: Tools > Customize > Options: Show Standard and Formatting 
toolbars on two rows 

� ENABLE: Tools > Customize > Options: Always show full menus 

 Excel 

� ENABLE: Tools > Options > Save: AutoRecover save location: h:\data\myfiles 
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� ENABLE: Tools > Customize > Options: Show Standard and Formatting 
toolbars on two rows 

� ENABLE: Tools > Customize > Options: Always show full menus 

 PowerPoint 

� ENABLE: Tools > Customize > Options: Show Standard and Formatting 
toolbars on two rows 

� ENABLE: Tools > Customize > Options: Always show full menus 

 Project 

� ENABLE: Tools > Customize > Options: Show Standard and Formatting 
toolbars on two rows 

� ENABLE: Tools > Customize > Options: Always show full menus 

 Publisher 

� ENABLE: Tools > Customize > Options: Show Standard and Formatting 
toolbars on two rows 

� ENABLE: Tools > Customize > Options: Always show full menus 

 Visio 

� ENABLE: Tools > Customize > Options: Show Standard and Formatting 
toolbars on two rows 

� ENABLE: Tools > Customize > Options: Always show full menus 

 Word 

� SET: View menu to Print Layout 

� SET: Zoom to Page Width 

� SET: Click Read button and set Toolbars to be on two rows 

� SET: Tools > Options  File Locations > Documents: h:\data\myfiles 

� SET: Tools > Options  File Locations > AutoRecover files: h:\data\myfiles 

� REMOVE: Research Button 

� REMOVE: Permissions Button 

� DISABLE: Tools > Options > General: Automatically Create Drawing Canvas 
when inserting Autoshape 

� DISABLE: Tools > Options > General > Service Options: Customer Feedback 

� ENABLE: Tools > Customize > Options > Show Shortcut Keys in ScreenTips 

� ENABLE: Tools > Customize > Options: Show Standard and Formatting 
toolbars on two rows 

� ENABLE: Tools > Customize > Options: Always show full menus 

19. Configure Adobe Acrobat Reader 
 DISABLE: Preferences > Updates: Automatically update 

 DISABLE: Preferences > internet: Allow fast web view 
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 DISABLE: Preferences > Internet: Allow speculative downloading in the 
background 

 SET: Preferences > Internet: Connection Speed = 56 k 

 Open Internet Explorer and open a PDF 

20. Configure Quark 
Edit C:\program files\quark\QuarkXpress 6.0\ QLAClient.properties 

 Set QLASERVER = quarkmanager.westminstercollege.edu 

 Set port to 55555 

21. Configure Real Player 
 Tools > Preferences: 

� General: On startup display – Player only (no Media Browser) 

� Connection > Internet Settings 

 DISABLE: Send Connection-quality data to RealServers 

 DISABLE: Enable Cookies 

 Message Center 

� DISABLE: everything (no messages at all) 

22. Install Zen Agent 
Install from W:\tools\w2k-xp\current client\ZfDAgent.msi 

 Install: All 

 Launch application explorer when windows starts 

23. Look and Feel 
 Turn volume to 2nd notch 

 Disable startup and shutdown sounds 

 Quickbar 

� Copy the GroupWise shortcut to the quickbar 

� Copy the Microsoft Word shortcut to the quickbar 

� Arrange quickbar icons to be Desktop, IE, GroupWise, Word 

� Erase all other icons from desktop and from quickbar 

 Start Menu 

� Put all MS Office related icons in a “Microsoft Office” Folder above Programs 

� Delete Messaging Shortcut 

� Delete Windows Catalog shortcut 
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� Delete Remote Assistance Shortcut 

� Delete PrintMe Program Group 

� Delete "Set Program Access and Defaults" 

� Delete all shortcuts from StartUp except Application Explorer 

� Move Windows Update to Programs in Start Menu 

� Copy Windows Explorer to Programs in Start Menu 

� Sort Program in Start Menu by name 

 Internet Explorer 

� Download file to Desktop 

� Clear Internet Explorer History 

� Delete Temporary Internet Files 

� Delete Cookies 

 Desktop 

� Arrange desktop icons to be My Documents, My Computer, Network 
Neighborhood, Recycle Bin, Internet Explorer, GroupWise 

� Rename My Documents to My Files 

� Empty Recycle Bin 

� Remove Quicktime from System Tray 

 Novel Location Profile 

� Right click on N in System Tray > Properties > Location Profile.  Select 
Default > Properties.  Clear username, uncheck “save profile” 

� DISABLE: Dial Up Tab 

� DISABLE: NMAS Tab 

 Run Regedit 

� Create [HKEY_LOCAL_MACHINE\SOFTWARE\Westminster] registry entry 

� Create String [HKEY_LOCAL_MACHINE\SOFTWARE\Westminster\version] – 
set to image year (e.g., 0506) 

 Run Msconfig 

� DISABLE: startups qttask.exe and jusched.exe.   

� Reboot.   

� After reboot, check “do not show this menu again” 

 Clear Documents: Start Menu > Customize > Clear 

 Run Disk Cleanup 

� ENABLE: remove everything except installation files and compress files 

 Right click on My Computer > Manage > Services 

� DISABLE: terminal services and remote registry 
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24. Disk Tuning 
 Run Disk Defragmenter from Start > Accessories 

 Run chkdsk from command line 

25. Novell Network Administrator Configurations/Settings 
A Novell network administrator must do the following: 

 Configure JVM 
Change the registry with Textpad to reflect the new install path. 

26. Configure Profiles 
 Log into Novell using an account without a Dynamic User profile and into windows 

as the temp account 

 Set view properties to see hidden files 

 In System Properties > Advanced > Performance > Profiles copy the IT profile to 
c:\documents and settings\Default User 

 Log in as Administrator and create a password 

 Log in as IT and create a password (1mag30506) 

 Delete temporary account 
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Post Initial Image Release: Fixes, Changes and 
Updates by Date 
Prior to making fixes/changes to the image: 

 Log in as IT, password: 1mag30506 (workstation only) 

 Create a temp account without a password 

 Logout, then log in as temp user 

 Make changes/fixes 

 Logout, then log in as IT and be sure you can view hidden files/folders 

 Right-click My Computer > Properties > Advanced > User Profiles > Settings 

 Select the temp user account > Copy To C:/Documents and Settings/Default User 

 Delete temp account 

 Control Panel > User accounts > delete Temp account and files 

 RUN FINAL STEP (SEE LAST PAGE) FOR EPOLICY REGISTRY FIX 

1. Switch to Microsoft Update (10/24/05) 
I have changed this in the documentation above.  Microsoft has consolidated 
Windows Update and Office Update into one service. 

2. Novell Bad Address Caching Fix (10/24/05) 
This fix address connectivity problems to Volga. 

 Right-click on N in task tray 

 Select Novell Client Properties… 

 Advanced Settings Tab 

 Set Bad Address Cache Timeout = 0 

 Set Bad Server Name Cache Enabled = Off 

 Set Bad Server Name Cache Timeout = 0 

 Reboot 

3. iPrint IE Popup Blocker Fix (11/17/05) 
This fix keeps IE from blocking iPrint printer installs. 

 Open IE, Tools > Internet Options > Privacy… 

 Open Popup Blocker 

 Add *.wcslc.net and *.wcslc.edu 
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4. Update Flash and Shockwave Players (11/17/05) 
New versions of the players have been released from Macromedia. 

5. MS Word “Save as Web Page” Fix (11/17/05) 
This fix sets the default file type extension correctly. 

 Open MS Word, change the default Save as Web Page to .htm (not .mht) 

� Tools > options > general > web options 

� UNCHECK “save new web pages as single web pages.” 
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(FINAL STEP) Epolicy Registry Key Fix for 
VirusScan 
This step must be done immediately before you upload the image to the 
GhostServer: DO NOT REBOOT INTO WINDOWS. 

 Delete HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy 
Orchestrator\Agent\AgentGUID 


